macOS App Installation

Hi, new user here, I’ve decided at the grand old age of 60+ to try to teach myself to touch type rather than the “hunt and peck” scheme with my two index fingers that I’ve been using all my life. I currently manage to go along at around 40wpm with pretty decent accuracy but I’d like to do better if I can, we shall see!

Anyway, paid my money and set up my account without any problems. Then followed the advice to download the desktop application and this all seemed to go well, icon appeared on the desktop etc. However, once I try to run the application the icon appears in the dock for a moment and then vanishes, it just doesn’t seem to launch properly and I can get no further with it.

Have tried deleting the Typesy application and re-installing it but this has made no difference, still the same problem.

I’ve raised a support ticket but any suggestions welcome. Using macOS High Sierra 10.13.6.

Thanks, Q

I am having the exact same problem on my Mac. My kids were all well and away learning to type and enjoying the program. Now I cannot access any help and the exact same things are happening to me as to you. I have tried everything to get it working again.

Hi Quentin and Kareen, apologies for what happened!

We are currently working on a fix with our Mac AppStore version.

Can you try opening the web application on a Google Chrome browser and see if the error still persists?

Web app:

We will update everyone on our social media pages once everything is okay.

Apologies once again for the inconvenience.

Thank you,